[COMPLETED] PLANNED MAINTENANCE
Incident Report for Mitto
Resolved
This maintenance has been completed.

Start: 2023-03-08 22:00 CET
End: 2023-03-08 22:05 CET

Thank you for understanding.
Posted Mar 09, 2023 - 09:49 CET
Identified
MAINTENANCE INFORMATION

Service Impact: No impact expected 

Service Purpose: System upgrade

Start: 2023-03-08 22:00 CET

Description: In order to improve and maintain platform stability, we need to make upgrades to our system

Customer impact: No customer impact is expected
Posted Mar 08, 2023 - 12:56 CET
This incident affected: Customer Portal/Dashboard.