This degradation has been resolved. We will continue to monitor the traffic with the operator to ensure no further issues are observed.
Start: 2025-02-18 21:00 CET End: 2025-02-19 06:30 CET
Thank you for understanding.
Posted Feb 19, 2025 - 06:40 CET
Update
Currently, there is ongoing emergency maintenance work at the operator's end and estimated to be completed on Wednesday at 10:00 am 02/19/2025 (GMT+03:30).
Posted Feb 19, 2025 - 04:28 CET
Investigating
Please be advised that currently there is a degradation in delivery towards Iran, RighTel, (432-20) You may experience irregular delivery with inconsistent delivery times while sending towards the specified network. Our dedicated team is working with the MNO to resolve the situation at hand, no estimated time of resolution can be provided yet.